printer problems - bjc3000

munch1976, Mar 24, 7:58am
Printer problems - bjc3000 I have just put a new canon ink cartridge in. The old one was working fine, until it ran out of ink.
but now.....try to print something, and nothing happens - it sounds like it is printing, but nothing on the paper.
i have deep cleaned, head realignment, tried test patterns.
printer is online, no resource conflicts....i'm stumped!!
this happened once before when i tried to used a non canon generic brand, but as soon as i replaced that with a canon cartridge, problem was fixed...
any ideas? anyone???

finfang, Mar 24, 8:41am
You probably have, but Have you made sure the cartridge has clicked fully into place. Use to happen to me on my 3000. Cheers


1clover, Mar 24, 8:56am
YEShave had the same exact problem with other brands - and put the canon in, and it works - I have realised that because these other inks are cheaper, sometimes some of them are empty or haved dried up - check the expiry dates on them before you buy, take them back if you have your receipt and ask for a refund. Good luck.

munch1976, Mar 25, 2:38am
Ok, will go and replace it with another one and see if that makes a difference....some of the forums say that these printers are well known for suddenly packing up

Share this thread

Buy me a coffee :)Buy me a coffee :)