Vista, USB mouse not working.

tradeagain2, May 19, 4:53am
Vista, USB mouse not working. Hey, I have a Vista laptop and my USB mouse has always worked just fine until recently. Now when I plug it in, the light on the bottom sometimes lights up but mouse can't be moved/clicked. The USB ports (there are 4) are all fine with Ipod, camera, USB stick etc. Luckily laptop has a touchpad so I can still use that, but not ideal. There are heaps of comments on the internet from people with similar probs, but it's all too complex/confusing for me to understand as not very computer mindedany help hugely appreciated if you have had this problem or know what to do :)

tradeagain2, May 19, 5:17am
Anyone :( I found this website which has helped a lot of people: http://anotherlab.rajapet.net/2008/04/work-around-for-kb938371-disabling-hid.html However this solution doesn't work for me, it says that my driver details are already up to date. The mouse (it is 'Genius' brand) has worked well for at least a year and still works on my friend's laptop, but doesn't appear on mine when I plug it in.


tradeagain2, May 19, 6:47am
Bump...

tradeagain2, May 19, 9:36am
Another bump desperate!

deodar, May 19, 9:41am
What does the Device Manager tell you? Be under mouse,you can update the
driver there too,highlight & click
properties-it will tell you the
problem or "This device is working
properly" which is aggravating-just
what you need.

deodar, May 19, 9:49am
Http://tinyurl.com/o2w653 Install SP1 & make mouse HID compliant.

wayne472, May 19, 10:40am
Change the batteries in the mouse and push the connect button beside the light.Even if the light is flashing your batteries are flat.

mitchellca, May 19, 10:54am
Some laptops...have a button above the touch pad that turns the touch pad on and off. This shouldnt normally make a difference whether or not the USB mouse should work, but maybe just give it a go. You never know! Might just work :)

matza4000, May 19, 11:43pm
.when you turn your mouse you should press the connect button

tradeagain2, May 20, 4:22am
Thanks for comments, I checked and SP1 (Service Pack 1) is already installed. I'm not sure how to make the mouse HID compliant, and would this work if the mouse has been working fine on this laptop up until now? Off to search on Google but will keep checking thread, thanks

tradeagain2, May 20, 4:26am
Oh and I'm not sure this type of mouse uses batteriesits an optical one which plugs in USB ports on my laptop?

trevix2k, May 20, 9:49am
Have you tried your mouse with another pc? or another mouse to your laptop?

deodar, May 20, 11:38am
That seems to depend on Driver type http://tinyurl.com/rcpt5m
Many have had this problem & this
is reported as 1 possible solution.

sambar1, May 20, 11:49am
I dont think it will be your mouse. The same thing is happening to me. Its a brand new lap top. I have tried 3 other mouses, but its the same in all 3 usb ports. When this is happening, none of the ports work for any of my USB devices. The computer says it finds a fault with the mouse and has shut down the USB ports. I have found if I reboot 2-3 times the ports work again. Its still under guarantee so the shop said, if it happens again to take it back in.
This has happened 3 times to me. Its a real pain.

tradeagain2, May 20, 11:52am
Yeah me too, Mouse works fine on two other laptops. It's frustrating and I'm ready to throw my laptop out the window! Doing a lot of data entry at the moment and using the touchpad is very impractical, so your suggestions are really appreciated. When I go into Device Manager from control panel, it says 'Sony firmware extension parser device' under Human Interface Devices and 'Synaptics PS/2 port Touchpad' under Mice, that's all

tradeagain2, May 20, 11:53am
I would consider just buying another cheap mouse but it appears that people have tried this (comments on Google) and it hasn't solved the problem at all :(

tradeagain2, May 21, 4:04am
Bump I don't know what else to do except call the Windows people?

Share this thread

Buy me a coffee :)Buy me a coffee :)