USB-Serial adapter problem

I have a car diagnostic scanner that uses an rs232 serial port. My laptop doesn't have a serial port, so I purchased a usb-rs232 cable with a driver. When I run the scanner, it says "hardware not ready". On a newer version of the scanner software, it says "please install adapter driver". I have tried a laptop that has the serial port and the scanner worked fine. How do I solve this?

geek_khairul23, Dec 4, 2:43 pm

see if you can get a pcmcia serial card ?

geek_drcspy, Dec 4, 2:46 pm

Some hardware won't work with the USB-serial port adapters because the device usees non-standard serial protocol. Some people say USB-serial port adapters just don't work at all and avoid them.

Look for used laptops that have a genuine serial port, a Dell C600 or a Toshiba, dedicate it for running with the scanner.

geek_gyrogearloose, Dec 4, 2:54 pm

That makes sense. Thanks.

geek_khairul23, Dec 4, 3:41 pm

Sounds feasible. Would this work like a normal laptop with built-in serial port, or would there still be possiblity some devices would still not work?

geek_khairul23, Dec 4, 3:49 pm

Have you tried the website of the Scanner for a Driver? Have you Googled the Make and Model number + driver? Have you looked for a Forum where people talk about the scanner? Most likely, they'll know how to connect to it via PC.

Before going to the expense of finding a new laptop, try Linux. Even puppy often recognises serial connections. Ubuntu or a debian distro is probably your best shot. There is an easy way to see if Linux recognises a serial connection. If it does, then going onward from there should be fairly easy.

geek_badcam, Dec 4, 4:42 pm

Try this:

Download and burn to CD Ubuntu. Restart your PC and let the PC set up a Live version of Ubuntu. Don't install it, just run the Live version.

Once it's started, plug the Scanner in and turn it on.
Open the Terminal/Console (Ctrl+Alt+F1 or find it in the Menu) and type:

"dmesg" without the quotes and hit enter.

I'm guessing here, but see if you see anything that looks similar to this:

ftdi_sio 1-1:1. 0: FTDI USB Serial Device converter detected drivers/usb/serial/ftdi_sio. c:-
Detected FT2232C usb 1-1: FTDI USB Serial Device converter now attached to ttyUSB0 ftdi_sio 1-1:1. 1: FTDI USB Serial Device converter detected drivers/usb/serial/ftdi_sio. c:-
Detected FT2232C usb 1-1: FTDI USB Serial Device converter now attached to ttyUSB1

Let me know.

You can also look in the Hardware option in the Menu (sorry, I'm running a headless server and I can't recall exactly the menu options) and look under USB Devices. You should see something like "ftdi_sio" and there'll be a reference to something like "ttyXXX".

geek_badcam, Dec 4, 5:18 pm

You have to go into device manager and determine serial port number, typically port 4, and then tell this to your scanner software. The software probably looks at port 1 by default.

geek_spyware, Dec 4, 5:40 pm

we use usb to serial convertors all the time and the only ones we find that work all the time with any software are the dick smith ones for about $19. 00.

geek_loud_37, Dec 4, 6:43 pm

There's a setting in the scanner software to choose port, and there's an option with the usb-rs232 adapter brand name.

geek_khairul23, Dec 4, 10:44 pm


I went to dick smith and only found something around $40.

geek_khairul23, Dec 4, 10:45 pm

quite a lengthy method, but I'll give it a try when I have the time. thanks.

geek_khairul23, Dec 4, 10:47 pm

go into control panel
go into device manager
look for com ports
look for the com port number
use this in your program
problem solved
i think

geek_upside_umop, Dec 4, 10:50 pm

bump for savanna91

geek_khairul23, Dec 28, 7:51 pm