Genius Videocam Trek doesn't work win7 64bit

kiwikidd77, Apr 14, 12:48am
Just did a reinstall in 64 bit mode of Win7 Ultimate now my webcam doesn't work... Grr, the software loaded OK and says I need to connect a cam to get it working.
Plug in the cam and it says No divers found.

Worked OK in win7 32 bit mode. No newer drivers available either.

Maybe I need to install XP and dual boot my system

rgtrading, Apr 14, 12:53am
Try running it in xp compatibility mode, you never know. So far I haven't encountered any 64-bit incompatibility problems.


kiwikidd77, Apr 14, 3:40am
x1
thanks. tried that but still no success. A friend had to replace his 2 year old printer because of Win7 Ultimate. Canon said it was too old to bother writing drivers for.

I have to wonder why the need to change drivers all the time when new OS is installed. Maybe a scheme to keep people buying new products all the time even when the older ones are still in good working condition.

rgtrading, Apr 14, 3:54am
That says a lot about canon then doesn't it.

kiwikidd77, Apr 14, 7:36am
True, avoid like the plague. I'm beginning to think the same about genius and their webcams.

Share this thread

Buy me a coffee :)Buy me a coffee :)