Printer Problems!!!!

ajay12, May 19, 11:23pm
We are using an Epson TX110 printer and have just bought a new black ink cartridge. However, my problem is that the printer will NOT recognise that a new ink cartridge has been inserted. Ive been through the How To steps on loading a new cartridge but no success. Ive shaked it well etc. The box just keeps coming up show black ink empty! ! ! ! Feeling frustrated, can anyone help? TIA.

r.g.nixon, May 19, 11:50pm
I guess there can be faulty cartridges. It is even possible that they can be damaged by static electricity - did you touch the exposed chip connections?


pyro_sniper2002, May 19, 11:53pm
Do they reccomend shaking them? I would have though that could cause air bubbles, which can cause the printer to read the cartrage as empty.

gasaxe, May 20, 12:09am
I have a chip resetter for Epson cartridges. There are a few for sale on trademe. Search for "Epson resetter" That should fix that cartridge and any others. Handy if refilling them yourself.

ajay12, May 20, 12:32am
Thanks for the advice. The trouble shooting instructions did say to give the cartridge a shake but little good that did anyway. Pretty sure i didn't touch the exposed chip. Bit annoyed I paid $25. 00 for nothing really.

ajay12, May 20, 12:33am
Thanks for the advice, will look into that.

kevin16, May 20, 12:34am
have you tried, . . turning off the printer and turning it on again?

ajay12, May 20, 12:42am
Done that a few times.

I have just looked on here for the chip resetters and they have every conceivable one, but the one i need, typical! ! !

hawkeye30, May 20, 3:31am
HIJACK lol i too am having problems with a printer but mines a brother 6yrs old and won't print keeps coming up with check maintenance and troubleshooting guide. Done that and done the things they advise but no luck. I have even tried to turn off at the wall for 2 mins and retry as that is supost to reset factory settings. Have you tried turning it off for a while?

Share this thread

Buy me a coffee :)Buy me a coffee :)