My mouse keeps selecting everything

My mouse keeps selecting everything instead of just letting me select one thing it keeps highlighting the whole lot! Its driving me nuts!! hwlp please

Read how to solve mouse keeps highlighting problem in the blog.

geek_tradeaddikt, May 9, 10:11 pm

.... it may seem odd. but have you rebooted your pc?

geek_charles.j, May 9, 10:56 pm

Well have you booted the pc in the guts and restarted it?

geek_dveditor, May 9, 11:19 pm

Give your mouse to the cat and buy another

geek_gorbulas, May 9, 11:33 pm

Are your computers networked? ...just asking.

geek_olack, May 9, 11:34 pm

Tradeaddikt she/he is currently cutting white tm powder and sniffing it thought green bills

geek_dveditor, May 9, 11:37 pm

Very likely that the Shift key On the keyboard is stuck on.

geek_mrfxit, May 10, 8:22 am

I bet you have a corded optical mouse,these are known to go out to lunch after a while,had 2 do this,time for a new one

geek_ntalke, May 10, 8:49 am

Its a very hard thing to train amouse properly..... if there something strange and it dont look good..ho you gonna call MOUSE BUSTERS call 0900mousetrain

geek_atilasgirl, May 10, 10:08 am

press SHIFT + ESC

geek_peter, Nov 19, 1:27 am

Cool, SHIFT + ESC did the trick.

geek_stubbe, Feb 11, 9:21 pm

OH MY GOD saved my life, same thing just happened to me - first day of a new job. freak out SHIFT +ESC - magic

geek_axe, Apr 7, 2:18 am

Try pressing the "Shift" rapidly several times, it should turn it off.

geek_granidi, Apr 15, 8:55 pm

Superb :)

geek_sairam, Dec 5, 5:16 am

OMG!!!! Shift + Esc saved my life :D TY!!!!!!!!!!!!

geek_--tim--, Dec 20, 11:56 pm

How do you replicate this problem?

My grandma called me saying: I dunno what to do, my mouse keeps highlighting everything.

Thanks for the solution for this mouse issue

geek_martok, Jan 5, 11:56 pm

Ha-ha-ha! So easy...spent ages trying to fix the problem. I even tried to scare my mouse with a cat ;)

geek_z00mbie, Jan 14, 1:03 am

THANK YOU SO MUCH
That was so annoying
SHIFT+ESC did the trick
Thank you thank you thank you
=]

geek_punkasschiick, Feb 9, 2:50 pm

many many many thanks.. i was having a headeach with this sh""""

geek_evaneac, Mar 1, 9:32 am

Very helpful thought it was some kind of virus!

geek_guest, Apr 17, 12:29 am

thank you! i had the same problem and you fixed it!

geek_guest, Apr 22, 6:56 pm

awesome! it worked for me. it highlighted everything, i could only type in capital letters, very weird. where is the problem, anyway?

geek_guest, Jul 1, 8:24 am

oh and also couldn't scroll

geek_guest, Jul 1, 8:25 am

wow thanks a lot..

geek_neetu, Aug 11, 9:56 pm

looks like the artifact of a missing frame buffer, the problem is in windoze.

geek_kmonk, Aug 22, 8:26 pm

Thanks a lot,, it saved mine toooooooo :)

geek_meghana, Sep 1, 10:33 pm

Wow...I changed the batteries, rebooted my pc, updated the drivers,uninstalled, then reinstalled, ran a virus scan, and basically went out of my mind insane........and the whole problem was the damn shift button on my keyboard lol....genius...thanks, you saved me from buying a new mouse, and prob a new tv too, as I was prob going to end up throwing the mouse through it

geek_guest, Nov 9, 4:07 am

Uhm, this is just the settings for Sticky Keys. You can shut them off in the Accessories menu of any Windows OS. For XP, its in keyboard settings, in Vista/7, it's in the Ease of Access Center, under keyboard options.

geek_guest, Jan 9, 8:54 pm

Should clarify; XP is: Start menu>Accessories. Vista/Windows 7 is Start Menu>Accessories>Ease of Access Center. You can change whether or not this setting comes on at all, but by default, the Shift, Ctrl, CapsLock and NumLock keys do special things when hit repeatedly (usually 5 times in a row).

geek_guest, Jan 9, 8:56 pm

Shift plus escape, yes!
Also, I tried hitting the shift button quickly- not sure which did the trick, but it works now.
Thank you!

geek_guest, Jan 14, 5:41 am

hold shift+esc

geek_aznawesome, Jan 16, 5:26 pm

Thanks alot it worked well by pressing the shift key
:)

geek_guest, Mar 15, 6:47 pm

indeed helpful, my shift was stuck, tks!

geek_guest, May 6, 9:52 pm

Thank You ! My mouse was pre-selecting words and I was gonna throw it at the wall til I found this !

geek_lisaj, Dec 2, 12:46 pm

Wow, thanks, the SHIFT + ESC did the trick! Was pretty darn close to losing it.

geek_guest, Dec 20, 4:38 pm

Thanks Shift+Esc work properly

geek_guest, Jan 2, 11:22 pm

A great response... it was driving me crazy~

geek_resa, Jan 15, 6:47 am

Omg thank you! It means alot. :) high five!

geek_guest, Jan 16, 9:14 pm

Pressing both shift keys rapidly worked for me

geek_guest, Mar 14, 6:47 pm

Just had the same problem now solved thanks to this info.

Big Thanks to posters.

geek_guest, Mar 22, 4:14 am

If i could, i would make sweet sweet love for your help today geek mrfxt :D

geek_guest, Aug 22, 3:12 pm

SHIFT+ESC WORKED!!! THANK YOU SO FRIKIN MUCH. God bless you!! :-)

geek_nowilovegeeks, Sep 3, 2:59 am

In my case pressing shift keys many time opened up the sticky keys box. Selected it and Wallaaaaa!!!!! Thank you

geek_guest, Sep 3, 5:26 am

SHIFT + ESC SAVED MY LIFE ty

geek_guest, Oct 8, 10:20 pm

Shift & Esc saved my life too!!!!! Holy cow, thanks a million!

geek_guest, Oct 17, 1:35 pm

DOES NOT WORK IN CHROME
shift esc only brings up the Chrome tasks

geek_zeno, Jan 4, 1:56 am

Thank, Shift was stuck.
i must be dump

geek_guest, Oct 1, 3:11 am

thank you so much geek_peter , thank you

geek_guest, Jun 14, 7:06 am

Pressing both shift keys at same time works too.

geek_guest, May 13, 6:10 pm

I just did a Google search because my mouse was doing the same thing, except only in Gmail. None of the other fixes worked so I just turned my mouse off, left it off for a few minutes as I went to the kitchen for a bowl of ice cream, then turned the mouse back on.
Voil?! It's working right again.
(I don't know if this had anything to do with it, but it was vanilla ice cream with vanilla bean specks.) ;-)

geek_oldilocks, Aug 31, 4:12 pm