USB to PRINTER IEEE 1284 Parallel Port Cable

gazza1234, Jul 30, 4:25am
Anyone got any experience with these?
I got one the other day as need to run a 2nd parallel only printer from my laptop.
My existing external hub has parallel and 2 serial ports, and these all work fine.
This new cable only one, seems to be recognised by the computer and auto installs usbprint support, but nothing prints.
There was no driver supplied with the new cable.
When I print, the job leaves the print manager, then dissapears, with nothing being printed. Have tried printing direct to port also.
My hub gives me real looking ports listed in my device manager ie LPT1, Com1, Com2, but the new cable doesn't show anything in the ports section, just USB printing support under USB controllers.

Should these devices need drivers? and if so, how can I identify what drivers as the cable and packaging has no manufacturers marking on it?
I've tried setting printer to USB001 - 004 ports and watched the list change as the cable plugs in to see what the most recent one is.
I can unplug the cable from the printer, plug in a std parallel cable from my Hub and that prints fine.

Any help would be greatly appreciated.

chito, Jul 30, 4:35am
I have installed a few of these. Sometimes I have had to delete the printer driver and let it detect and reinstall it's self. Other times, I have had to install the printer driver first as a local parallel printer, then change the port to USB001 etc. There is often a cd supplied, but that was only needed for windows 98. I have only installed on XP and vista.


chito, Jul 30, 4:38am
I have also had them show up on device manager, but still be faulty.

gibler, Jul 30, 5:10am
they tend to work (or not work) depending more on the model of printer. What printer model is it?

gazza1234, Jul 30, 5:11am
Thanks. I'll try the print install on lpt first, then change to usb and see what that does. It seems pretty easy to waste an awful lot of time on these things.

gazza1234, Jul 30, 6:53am
No joy with that change.
Have also deleted all printer drivers and tried the Windows printer drivers only, but still no go, and tried on 3 computers.
Maybe I've got a dud cable.
I think I'll buy another hub and chuck this cable in the bin.
No reply from seller either at this stage.

computerpro, Jul 30, 7:01am
Don't throw it away yet - I install these a lot - install the drivers on the CD & usually you set the printer to LPT2

gazza1234, Jul 30, 7:10am
There was no CD in the sealed pack, no manufactures markings, nothing to identify a make? I even tineyed the sellers photo of it, but only came up with Russian sites, and no drivers.
http://tinyurl.com/28wlh8z

computerpro, Jul 30, 7:39am
This is the cable I use - comes with drivers etc. Unfortunately there's a lot of junk cables mixed with the good & it makes it obvious when the seller doesn't want to know. http://tinyurl.com/atencable

gazza1234, Jul 30, 9:39am
Yeah, like I said. I think I'll bin this one and buy a decent one. . ie one that actually works. Cheers

richms, Jul 30, 10:21am
I have used 2 cables like that on older epson recipt printers and they have just worked, but what was on linux.

gazza1234, Aug 4, 7:00am
A big thank you to computerpro. Bought the cable you recommended. . from you of course, plugged it in, hey presto, all good.
All that time with the other crap cable was just a waste of time and effort. Thanks again.

Share this thread

Buy me a coffee :)Buy me a coffee :)