My printer won't print black!

bphuong, Oct 18, 8:39am
I have a Brother DCP-330, it's about a year old. It's not printing black despite ink management saying it's full. I have tried a new cartridge and still no luck! It has to be some other problem.. any suggestions?

castlerea, Oct 18, 8:41am
have you checked your colour cartridge?My printer refuses to print black if the colour cartridge is empty (even when the black is full).


bphuong, Oct 18, 8:43am
Yes, the all the catridges are full, I have just gotten them all refilled.

bphuong, Oct 18, 9:57am
Yeah I removed the tape. I actually refilled the cartridge that came with the printer after using these other ones I bought. Perhaps there is a blockage somewhere inside.

gyrogearloose, Oct 18, 8:24pm
If there is any colour on the page, then the printers will use the colour cartridges and what appears to be black will be a mix of all the colours. It only uses the black cartridge, if EVERYTHING on the page is black. So this could well be a problem with the colour cartridges. Type up something in Notepad and see if black is back.

bphuong, Oct 19, 4:10am
That's interesting. I've done that but still no luck!

footplate1, Oct 19, 5:34am
I have a Canon MX 700 and it hates refills.But I do find that going through the ritual of nozzle-checking and cleaning is generally useful.Don't know Brother but probably has similar features to CANON.

fifie, Oct 22, 6:32am
Have a Brother printer, different model, it done the same as yours #1 and it hates refill, or compatible cartridges. Was getting ready to throw it out lol and gave it one last shot cleaned the heads and putblack and all colour new brother inks in it and it goes like a charm again.

bphuong, Oct 23, 10:30am
Right because I used these cheaper cartridges when it started to go pear shaped. I refilled the cartridges it came with so I guess mine hates refills too! Might just have to try a brand new cartridge then!

Thanks for the help everyone!

malachiman, Oct 23, 10:36am
use black paper and print white, should solve your problem

badcam, Oct 23, 10:41am
This happens to my folks printer all the time. Take the cartridge out (you may have to do them all, but just the black the first time). Turn the printer off at the wall, or pull the power cable out. Let it sit for a couple minutes and then put the cartrdige back in and turn it on.

If that doesn't work then you do the same thing but you hold the "power save" ( the rubber power button) down when you turn it back on. Keep it held down for 10 or 15 seconds.

That should reset the ink settings.

bphuong, Oct 26, 9:52am
I gave it a shot badcam, but still no luck.. I think I should just buy a new printer!

Share this thread

Buy me a coffee :)Buy me a coffee :)