Printer Issues What have I done wrong?

somethingsexy, Nov 14, 8:57pm
Hi Guys
Please can someone tell me what I have done wrong?Yesterday my printer (brother MCF-290C) ran out of black ink so I changed it, and told the printer i had done so.I have just tried to print a page and it still prints with no black ink.How do I reset it, so it prints correctly?

peter148, Nov 15, 1:58am
Is the replacement cartridge new or a refilled one?Check you have peeled off then sticky tape (if any) from the ink head on the cartridge.
Go into Printer Properties, run the Maintenance utilities such as nozzle check, etc, then try to print a text page.


bluetongue, Nov 15, 2:18am
give it a few goes.

ceedoubleyou, Nov 15, 2:38am
reboot, fixes 99% of everything!

little_egypt, Nov 15, 2:42am
Or get Linux!

rhubarb57, Nov 15, 2:48am
run it through test print i had to do this 4 times to get my printer to print after changing inks

somethingsexy, Nov 15, 4:46am
I have tried copying things and they come out as they should its just the printing which comes out minus the black.Will run the nozzle clean etc now and update everyone later.Thanks everyone

drcspy, Nov 15, 6:15am
well if copy works in black theres NO point in wasting ink doing a nozzle clean is there ?

check the printer settings

guest, Mar 9, 1:59am
OK This is giving me the shits - I have a brother mfc290c i have replaceed the black ink cart. twice its still not printing any docs - the colour works fine but want to print out your school or work doc's i can use the excuse my printers rooted ..... then he would say what type of printer , id say brother and he would say oh thats ok then i understand... ok enough of the sarcasticness any one got any ideas?????????? please

Share this thread

Buy me a coffee :)Buy me a coffee :)