ISky firefox plugin on Linux Mint?

I can't get any Sky On Demand items to play on either FF11 or Chrome17 on Linux Mint 11.(iSky.co.nz - for my Sky subscription)

The content rating plays OK as does the Sky ad that follows, but the program video will not load/play - there's a clockwise arrow on the screen - up to an hour, but no video.

Sky have checked this through with me - went out of their way to do so, they could use my login details to see the content, and using the Web Developers console could see where the loading stopped, but couldn't explain why.

Tried two other different brands of adsl2 routers, same problem.Tried my daughter's Vodafone broadband account - same issue.

So it's NOT the router, or my Orcon account - it's something on my PC.

I can view OnDemand on TV3, TVNZ, and see embedded video on NZ Herald, U-Tube etc, etc,

What format do Sky use for their Catch-up video!

Does it need a browser plugin!

geek_duggin, Mar 20, 9:03 pm

Strictly speaking I don't think your Linux box is a compatible version of Windows: https://skytv.custhelp.com/app/answers/detail/a_id/1171

The only other clue I see is regarding Adobe Flash, must be version 10 or higher.

TVNZ and TV3 require specific sites to be unblocked - doubleclick etc - but I don't see anything listed for iSky. If you are using a HOSTS file, adblocker or popup blocker, try turning those off for testing.

edit: if nothing helps, contact Sky again next time you are passing Mt Wellington, I know those guys would be interested in looking to resolve it - try 3pm on a Friday.

geek_gyrogearloose, Mar 20, 9:11 pm

The error message on Windows XP SP3 for the same issue is "The selected content is unavailable."And that's on a vodafone broadband account too.

geek_duggin, Mar 20, 9:31 pm

Where's the smiley face!

geek_duggin, Mar 20, 9:32 pm

This could be a problem with Sky's server.

geek_gyrogearloose, Mar 20, 9:33 pm

Possibly, but my daughter can login to my iSky account on her laptop AND desktop - both Win7 and view OK.

geek_duggin, Mar 21, 9:57 am

I'mregistered for iSKy and have Mint 10. Got a specific programme that I can test!

Give me a link.

geek_badcam, Mar 21, 6:03 pm

Hi, sorry for the delay.Any on the Basic subscription - I can't play anything - and thanks bc.

geek_duggin, Mar 23, 9:22 pm

it's not working for me either, on firefox

geek_nicki5, Apr 18, 10:24 pm

You have to use Orcon's DNS numbers. Other ones won't let me stream from iSky.

geek_r.g.nixon, Apr 18, 10:27 pm

Thanks Ross, done that, but no change.PITA!

geek_duggin, Apr 20, 11:18 am

Do you have Gecko Media Playerinstalled!

Have a look in firefox >> about:plugins (in the address box) to see if it is.

If not it can be installed by opening mintinstall look for gecko-mediaplayer

geek_wickedtrader, Apr 20, 11:46 am


it seems adobe has not included some older os in there new version of flash player the misses is having trouble as well on mac os x 10.5.8 and she has to upgrade to 10.6 0r 10.7 to get the latetest player11.0

geek_fingerscrossed2, Apr 20, 12:01 pm


Edit
do you have the current version of flash player installed !

geek_fingerscrossed2, Apr 20, 1:05 pm

this is correct, put this in the DNS of the router and machine, make sure you release IP etc from machine and reload.
Know a few people that had the same problems (mac's and windows pc) once they put in the DNS reboot router and PC then it worked.

geek_mrtoken, Apr 20, 1:06 pm

this is correct, put this in the DNS of the router and machine, make sure you release IP etc from machine and reload.
Know a few people that had the same problems (windows pc) once they put in the DNS reboot router and PC then it worked.

geek_mrtoken, Apr 20, 1:06 pm

Linux flash is not being updated past the current version, which I have installed.Thanks.

geek_duggin, Apr 21, 10:12 pm

Have checked - was already installed, but reinstalled just to be sure.Thanks.

geek_duggin, Apr 21, 10:16 pm

I'm running DHCP server from the router, so the machines have been set to DHCP auto. This doesn't allow me to set DNS at a machine level - static IPs have to be set on the PC to get an option to set user DNS.

I tried this yesterday, and spent several hours getting settings back to normal so I can access the internet.Don't really want to go through that again.

But I'll try it again tomorrow afternoon when I've got some spare time.

geek_duggin, Apr 21, 10:21 pm

If your internet is with orcon then you have to use Orcons DNS settings, the CDN is hosted via orcon.Orcon has done something so that if you are their customer it comes right from their network.If you are with another ISP then most DNS's will work.
The only thing i know is that orcon customers must use Orcons DNS.

geek_mrtoken, Apr 22, 9:05 am

Thanks mrtoken - until I wanted to use iSky I always used OpenDNS without any issue - even as an Orcon customer.However as mentioned above this didn't work on iSky.

I changed my local machine network IPv4 settings this morning - about 9:30am - as reflected in this photo.

http://images.trademe.co.nz/photoserver/25/214459525_full.jpg then DNS in the router as per this,
http://images.trademe.co.nz/photoserver/80/214459480_full.jpg

and DCHP in the router as per this.

http://images.trademe.co.nz/photoserver/38/214459438_full.jpg

Tried it about 20mins ago.iSky still not working, but can browse anywhere else.

To remind folks - OS is Linux Mint v11, FF v11.Was told by iSKY help desk tech that Linux Mint isn't an issue.

Any other ideas before I consign this to the intellectual "Bin"!

Many thanks.:):)

geek_duggin, Apr 23, 3:31 pm

Thanks mrtoken - until I wanted to use iSky I always used OpenDNS without any issue - even as an Orcon customer.However as mentioned above this didn't work on iSky.

I changed my local machine network IPv4 settings this morning - about 9:30am - as reflected in this photo.(also used the Automatic DHCP setting as well without result.I changed the DNS setting in the router to "Use User DNS Settings" to match the local setting.No work either.)

http://images.trademe.co.nz/photoserver/25/214459525_full.jpg then DNS in the router as per this,
http://images.trademe.co.nz/photoserver/80/214459480_full.jpg

and DHCP in the router as per this.

http://images.trademe.co.nz/photoserver/38/214459438_full.jpg

Tried it about 20mins ago.iSky still not working, but can browse anywhere else.

To remind folks - OS is Linux Mint v11, FF v11.Was told by iSKY help desk tech that Linux Mint isn't an issue.

Any other ideas before I consign this to the intellectual "Bin"!

Many thanks.:):)

edit to explain AutoDHCP setting in both router and local machine.

geek_duggin, Apr 23, 3:31 pm

DNS relay can you change that so you can put the DNS in there!

Next test i would do is setup the dns on the router and put a windows machine on the network and see if a windows machine works.
If that does then its linux, if it doesn't then its the router

I know it works with orcons dns (and only orcons dns when your a orcon customer).

geek_mrtoken, Apr 23, 3:56 pm

Many thanks mrtoken.

Worked on my grungy XP box, but not on Linux Mint.Blast!

But thanks for your help, and to others who also commented.

Kind regards.

geek_duggin, Apr 23, 4:24 pm

Sorry could not be more help, i am more a windows guy than linux :P

geek_mrtoken, Apr 23, 4:27 pm

I seem to have the same problem. I was using LinuxMint 12 and now LMDE and I can watch live iSky but not Catch Up using either Firefox or Chromium.
I checked on my Windows 7 virtuabox machine and it works fine so that eliminates my internet setup as a problem.
I have an Orcon Genius account.

geek_robfish, May 17, 9:03 pm

I can only watch isky on one of my computers at home but cant figure out why the other comp wont play the programe but lets me watch the add before the endless arrow with nothing happening.

geek_guest, Oct 24, 5:25 pm