Word default spell check

I am absolutely peeved off with the Microsoft word spell check.The default language set on my computer is English (New Zealand).Several of my documents come up with the English (US) spell check and I cannot add a word to the custom dictionary.In earlier versions of Word, I could highlight the whole document and change the language to English (New Zealand).Word 2010 does not have this usefull feature.Can anyone help me!

geek_samsnan, Apr 30, 11:04 am


open word go to review then click on language and click on set proofing language select nz as default

geek_fingerscrossed2, Apr 30, 11:36 am

Thanks fingerscrossed2.I did what you suggested.The default was already English New Zealand.Returning to the document I was spell checking, nothing has changed.The annoying thing is that in earlier versions of Word I could highlight the text and change the checking language.This function appears to have been left out of Word 2010.

geek_samsnan, Apr 30, 12:37 pm

Any other suggestions please!

geek_samsnan, Apr 30, 3:10 pm

switch to OpenOffice or Libreoffice where you can still highlight the text and switch the language.

geek_little_egypt, Apr 30, 3:18 pm

Excuse the ignorance but what do you mean by Openoffice and Libreoffice!

geek_samsnan, Apr 30, 3:44 pm

they're programs free off the net excellent office programs, google em

geek_drcspy, Apr 30, 3:45 pm


emm interesting i can select the checking language must be something you have'nt got set up i'll have a look in to it later unless somebody here can help you out a wee bit busy at the mo sorry
edit at the botton of the spell check box you will see dictionary laguage click on the drop down box and scroll down till you see nz

geek_fingerscrossed2, Apr 30, 3:54 pm

Thanks fingerscrossed2.I do what you have said.It works for the word being checked and then returns to the other language.Also it will not let me add the word to the dictionary.Very frustrating.

geek_samsnan, Apr 30, 5:20 pm

Go to "File" -"Options" - "Proofing" and make the changes there.See if it makes any difference!

geek_kew, Apr 30, 6:26 pm

Kew - have followed your directions.Under Custom Dictionary, it has English (New Zealand) and a tick in the box by Custom.dic (default).Belo that it has the Dictionary language English New Zealand.

geek_samsnan, Apr 30, 8:14 pm

Try changing the last setting from "English New Zealand" to "All Languages"

geek_kew, May 1, 5:53 am

Hi Kew
It helped.Tried it out on a word document for which (for some unknown reason) used English (US) as the word check.It did work but new words were put in the US dictionary.My frustration is that in previous versions of Word I could highlight the whole document, change to English NZ and then continue checkingin the English NZ language.I could then add a new word to the dictionary and complete the spell check.

geek_samsnan, May 1, 9:26 am