Wireless Printer - Cannot connect.

angelzw, Jul 18, 11:16pm
Have a brand new laptop running Win 7. A brand new wireless printer Epson NX635. Is it possible to connect wirelessly to the printer if I use a Vodem stick to connect to the internet! I can see my home wireless network on the printer and on the laptop but nothing else. This laptop will not be staying here however, my point being that I know the wireless is working and enabled on both the printer and the laptop. Laptop and printer are going to be used on a road trip in a campervan hence the Vodem stick. Can anyone help! Thanks in advance.

lostdude, Jul 18, 11:35pm
No. The vodem stick is not a switch/router. You need a wireless access point or router to network the 2 together.


lostdude, Jul 18, 11:35pm
No. The vodem stick is not a switch/router. You need a wireless access point or router to network the 2 together. Or adhoc them but this is rather cumbersome and tricky to get working.

angelzw, Jul 18, 11:41pm
Thought so. Not sure how to setup adhoc. Will google as it's the only option.

king1, Jul 18, 11:54pm
This is a better option.

angelzw, Jul 19, 12:02am
Yip, it is. Can't get the printer to print using the adhoc. Got them seeing each other but that's all.

stu214, Jul 19, 12:31am
OK, dug out a DLink Wireless router. Connected to laptop wirelessly, connected and showing on printer. Still can't print! Please help! Not sure where I'm going wrong. When I print a test page it just gives an error in the print queue.
** Sorry posted on wrong account!

angelzw, Jul 19, 12:45am
OK, dug out a DLink Wireless router. Connected to laptop wirelessly, connected and showing on printer. Still can't print! Please help! Not sure where I'm going wrong. When I print a test page it just gives an error in the print queue.

angelzw, Jul 19, 12:56am
Got it. Thanks.

newbie5, Jul 19, 12:58am
The printer needs to be plugged into the wireless router then configured to the laptop

angelzw, Jul 19, 1:33am
OK so connected the wireless router to the printer via ethernet cable. When I connect the laptop to the DLink it cuts out internet access on my Vodem stick. When I disconnect from DLink internet link is enabled on Vodem again. What am I missing!

lostdude, Jul 19, 1:40am
For starters, the make and model of all hardware in question. I.e. Laptop, printer and wireless router. You gave a hint of the make of the router (Dlink) but the exact model will go a long way towards solving your issues.

angelzw, Jul 19, 1:43am
Sorry. DSL G604T ADSL 2+. As soon as I disconnect from the DLink I get internet access but no printing. When I connect to the DLink I am able to print but my internet access cuts out on my Vodem! Laptop running Win 7. Printer Epson NX635.

lostdude, Jul 19, 1:58am
Give us a screenshot of your Network with both the dlink and vodem connected:

??? Right click the network icon on the notification area
??? Click "Open network and sharing centre"
??? Take a screenshot and post it here
(Instructions on how to take a screenshot if you don't know how http://www.wikihow.com/Take-a-Screenshot-in-Microsoft-Windows )

angelzw, Jul 19, 3:02am
Just cannot get it to work with both connected at the same time.

wombatunder, Jul 19, 5:48am
Pretty vague descriptions here but how about getting clear about what you have set up:
1.Mobile broadband via Vodem, gives Internet access to a device with a USB port.Plug it into a laptop/netbook/desktop PC and *that* device gets access to the Internet.The Vodem is NOT a router so it can't act alone as the router for multiple devices on a local area network.
2.Your ADSL router *can* be a gateway between the Internet and multiple devices (wired or wireless) as long as it is connected to an enabled *telephone* line.Not much use in a caravan on the road.
3.A networked printer does not need or use Internet access.
4.If your router had a USB interface for mobile broadband, you could plug the Vodem into it and make the Internet available to both wired and wireless devices.Unfortunately, your modem/router doesn't have this feature.
5.You can buy (for not much) a wireless access point (WAP), such as the Edimax EW-7206APg, which will provide what you need.If you don't want Internet, you can just network your wireless devices with one another.If you have laptops, iPads, etc. with wifi, you just plug the Vodem into the WAP and those devices will have Internet access.

I just cite the Edimax as an example as I own one that worked like a charm for our network (3 laptops, a printer and two wired desktop machines) when we lost our Broadband port due to a house move (in a rural location).There are cheaper (and dearer) makes and models of WAP around and plenty of used ones on here, as well.Just make sure you get one that supports the USB interface or you'll be in the same boat you are already in with your ADSL router.

spyware, Jul 19, 6:26am
Simple to understand. When you connect to the Dlink you use DHCP. DHCP server on Dlink assigns an IP address to laptop. Unfortunately it also assigns a default gateway address which your laptop tries to use to route all traffic destined to go outside the Dlink subnet. You need to use static IP on wireless lan interface with no gateway address. All traffic on Dlink subnet will use this wireless interface, any other traffic will be routed via gateway as assigned by vodem.

drcspy, Jul 19, 6:28am
if the machine has wifi capability and win7 then connectify as an access point might work

lostdude, Jul 19, 10:11pm
OK, as above spyware probably hit the nail on the head but Windows 7 has an easier way to work around it than static IP addresses and gateways. Try this:

??? Whilst in that Network and Sharing Centre window, click on "Change adapter settings"
??? Press ALT to bring up the menu then click Advanced > Advanced Settings
??? Highlight your Vodem and click the green arrow on the right to move it up to the top

If your Vodem is already on top then do this:

??? Close the Advanced Settings window by clicking Cancel
??? Right click your Wireless Connection & click Properties
??? Highlight Internet Protocol Version 4 (TCP/IPv4) & click Properties
??? Click Advanced
??? Untick "Automatic metric"
??? OK your way back to the Network Connections window
??? Repeat the above but this time for the Wireless connection
??? Finally restart your computer

Share this thread

Buy me a coffee :)Buy me a coffee :)