Windows 7 won't copy to external storage

it used to, it's just started doing it, anything I plug into the USB drives, be it a memory stick or my tablet, it recognises it, shows it up etc, but when you go to copy anything, it just freezes and then shuts the drive down.I've done a system restore, no joy.Downloaded something called teracopy, it wouldn't do it with that.I plugged my tablet into my other computer running XP and not a problem, copied files onto it without a hitch.I'm at my wit's end as to how to fix it as it was all good before.

geek_tamzyn5, Nov 14, 2:35 pm

I've had trouble with that 64-bit Windows (7 & 8) won't play nicely with USB3 ports for some reason. It might be a Gigabyte chipset or driver problem. You could try deleting all USB devices (keyboard last) from Control Panel > System, then restarting the computer.

Our USB HDD is now sitting on an XP computer.

geek_r.g.nixon, Nov 14, 2:58 pm

I wonder why it worked though for like the last two or so months and then decided not to play nicely.I'm wondering if it's something else I've installed or an update or something that's doing this.

geek_tamzyn5, Nov 14, 3:00 pm

More info would help diagnose.
Is the problem with ALL USB ports! front and back!
Do any other USB devices work OK in all ports (USB mouse etc!)
Are you using Win7 64bit! or 32bit
Quote reviews: " In Windows 7 64-BIT, TERACOPY IS TOTAL JUNKWARE! It freezes up requiring a force close with Windows task manager. It fails to properly move folders from one hard drive to another. Many other bugs. Again, Teracopy is total crap in Windows 7 64-bit!"

geek_gj, Nov 14, 4:07 pm

I'm running win7 64 bit, the back usb's are working fine, they're running keyboard, mouse, foot pedal etc, fine, the side one's working okay with an external usb sound system.I just managed to copy some files to a reformated usb 2gig memory drive.I haven't tried the tablet again yet.

geek_tamzyn5, Nov 14, 4:23 pm

Again, have you tried the basics! Remove all unnecessary USB devices then connect the external. Try another working USB cable.

geek_lostdude, Nov 15, 7:50 am

Been using it in Win7 x64 since v2.0 & it hasn't skipped a beat. Seems those with problems are just PEBKACs. I haven't experienced ANY of the problems these people are describing in every system I've installed it on.

geek_lostdude, Nov 15, 8:08 am

Come to think of it Teracopy has done the same for me in Win 7 x64.

geek_pyro_sniper2002, Nov 15, 8:33 am

usb at the back that I run my foot pedal off stopped working, foot pedal wouldn't go, put it into another usb drive on the back and it installed the driver and is now working.Would these issues I'm having be something I could have looked at under warranty as computer is only 3 months old.

geek_tamzyn5, Nov 15, 9:53 am


Yes, its a possibility especially if the power supply is inadequate or faulty because all the items you are having problems with are not just data - they draw power as well. What are the specs for the PC!

geek_gj, Nov 15, 11:09 am

very high specs, 8 gig of RAM alone

geek_tamzyn5, Nov 15, 12:09 pm


That doesn't help USB ports. What about PSU spec!

geek_gj, Nov 15, 2:36 pm

It's an AIO which means it has an external PSU adapter. Maybe if the OP returns to the basics like I asked, we can establish whether or not it's another case of insufficient power to the USB ports.

geek_lostdude, Nov 15, 2:42 pm

I'm running my foot pedal on one of the side USB's that wasn't working for copying onto the tablet but is working fine with the foot pedal.The only other things plugged are essential which is the keyboard/mouse wireless plug, a usb powered speaker and a printer, which are all plugged into the back.The only thing I've added new in the last week or so is the powered USB speaker.

geek_tamzyn5, Nov 15, 3:27 pm

it's running an intel(r) core i7-2600s CPU @ 2.8GHZ with 8 gig of RAM

geek_tamzyn5, Nov 15, 3:31 pm