Help please 8.1 to 10

currently running 8.1 and registered and approved for upgrade to 10. Click on "Get windows 10 " window icon and get screen indicating it is downloading in the background. Same message for the last 4 days despite running for at least 8 hours a day. Did a bit of checking and it appears you have to be up todate with all MS updates which is set to automatic download and install. However when checking actual downloads find that there are dozens going back several months, all notated as "failed to install" and a check for MS updates now shows 4 urgent and 13 others. When click on install these 4 urgent updates , a popup window indicates the 4 serious updates are being installed but despite being left on for 6 hours no progress has been made. Still shows as % completed.
Is there a setting some where that is stopping all these updates from being installed ? Windows defender is off and Avira is on. Also run Malwarebytes and Ccleaner every month or so.

geek_rojill, Aug 8, 12:07 pm

Thanks. Ran the fixit and it came back with
Problems found
1) Service registration is missing or corrupt - - (Not fixed)
2) Windows Updater error 0x800 73712(2015-08-07-T-04-_03_28P (Fixed)
3) Problems installing recent updates (Fixed)

Any thoughts on what I need to do to fix Service registration ? Thank you.

geek_rojill, Aug 8, 4:18 pm

Not sure if this is same as you used but give it a shot. https://support.microsoft.com/en-us/kb/971058

geek_wayne416, Aug 8, 4:35 pm

Yes, and same answer as in #3 above.

geek_rojill, Mar 12, 5:09 pm

Share this thread