Who is the freeview box expert?

Have here a dishtv s7070. it is connected to sat dish. previously was going perfectly until someone else unplugged from the old tv and plugged it into the new tv. Have checked that it is plugged in right and now have a pic on the TV in the AV mode. Unfortunately it says no signal. Have tried factory reset but now have database empty. Am I right in thinking that it is probably the dish outside that is faulty?

geek_kiwibookhunter, May 19, 4:23 pm

If the dish outside was OK before you unplugged the box, it is probably still OK. Doing factory reset will have deleted all channels from your box. You now have to re-install them by following the instructions in the manual.
If you haven't got a manual you will find it online, just google dish tv s7070 manual.

geek_conjac, May 19, 4:45 pm

Have done that. it is one of those plug it in and push the button and away it goes - IF there is a signal. No signal no dice.

geek_kiwibookhunter, May 19, 4:50 pm

Might sound like a dumb question, but you plugged the Sat cable into the right one, eh? Our DishTV set tops both have 2, one for Sat in and a loop out.

geek_morticia, May 19, 4:54 pm

Plug-in and push the button only works when you first buy it and it comes with pre-installed settings. factory reset has lost all these settings.
You now have to do it all yourself from the manual. See pages 13,14 etc.
You probably have to choose a satellite (optus D2 I think, but possibly D1)
and the do a blind scan.

geek_conjac, May 19, 5:03 pm

If you still have trouble try ringing Dish TV support people 0800 347488 and ask them to talk you through it.

geek_conjac, May 19, 5:13 pm

Okay so the dumb question about the aerial cable may not be so dumb after all. I have plugged in the aerial from the dish straight to the right spot on the box but what's this about a loop?

I followed the instructions for reseting that was on the freeview website. Still no dice.

That 0800 number may come in very handy tomorrow morning after I have pulled out all my hair tonight.

geek_kiwibookhunter, May 19, 5:29 pm

The function of the *loop* connection is to attach a second receiver instead of using a splitter.

Is the receiver an S7070 or a S7070R ?

geek_blenheim-trader, May 19, 6:10 pm



Does it have two plug sockets that look the same on the back? Ours are S7070R and have 2, one is the aerial in and one is labelled Loop. If you have two and plug it into the wrong one, you won't have any signal to tune in.

geek_morticia, May 19, 6:13 pm

The new TV probably has more than one AV mode.

The handbook for the dish tv s7070 is available if you google it.
It is a PDF, so save it to your computer.

geek_budgel, May 19, 6:59 pm

Okay so heres how it went. Rang the dishtv support - Ryan. Had everything plugged in right. It is just put in the password (0000) push factory default, set an area (it doesn't even have to be the right area) and then scan. If that doesn't work it is not the box. Did that, no dice. Put another box in this time a veon one borrowed and brand new in the box. Plugged it all in and rang THEIR 0800 number and guess what? It was Ryan again! Different box different maker, different 0800 but same dude. And guess what? The procedure was identical down to a T. Still no dice. So it has to be the satellite dish! Maybe replace the bit in the middle that the cable is screwed to?

geek_kiwibookhunter, May 20, 11:00 am

Can you try connecting the box and the old TV back together and seeing if you get any signal at all? As written, it was the change of TV that apparently caused the signal failure, right? - Worth starting there imo. :)

geek_zirconium, May 21, 6:52 pm

Does the TV say no signal, or do you get the Freeview menu on the TV and that says no signal?

geek_loud_37, May 21, 7:11 pm

Whats the make and model of the new tv?

geek_marywarren, May 23, 4:00 pm



TV shouldn't be in AV mode it should be using HDMI 1 or 2 connection

geek_scuba, Oct 25, 4:03 am

Share this thread