Firefox update

just updated ff version 2.7 to 3.8 and now it runs slow to load google and gmail, it hangs when you go to exit.
anyone else having the same

geek_newbie5, May 21, 8:55 pm

I'm running 38.0.1 (Probably the same version as you) and it works fine.

geek_mark.52, May 21, 8:58 pm

yes it is 38.01 worked fine until the update .did the same 2 days ago so restored back earlier and worked fine .
yesterday it updated again and slowed so restored again same has just happened again tonight so figured it must be the update

geek_newbie5, May 21, 9:12 pm

No problem here. 38.0.5 beta something.

geek_r.g.nixon, May 21, 9:18 pm

my hdd is just about full would that have something to do with it.
Only about 5gb spare

geek_newbie5, May 21, 9:25 pm

Hard to say. Could be a corrupted file. Could be a dodgy add-on.

One option is to install MozBackup. use that to back up Firefox and Thunderbird stuff. Uninstall Firefox, after checking you have saved the download. Then check for any leftover Mozilla and Firefox folders and delete them. Some may be hard to find. Then reinstall. Then restore settings using Mozbackup.

geek_r.g.nixon, May 21, 9:34 pm

ok thanks r.g.

geek_newbie5, May 21, 9:48 pm

if your running a 64 bit system try "palemoon"
its quicker than firefox and less bugs

geek_sakkara, May 21, 10:16 pm

i run linux and firefox is iceweasel on kde just got a new one 38.0.1
you have to reboot on winblows , on linux you kill the browser and restart it after update i usually just used the deadly mouse pointer but be carfull what you click on it kills anything including your desctop if you click on desctop instead right mouse button to undo the deadly SKULL pointer on KDE linux ctrl-alt-esc is the 3 buttons to press to make the ponter deadly

geek_intrade, May 22, 8:44 am



No you don't.

geek_vtecintegra, May 22, 10:48 am

Right. Just restart Firefox, don't boot the computer.

geek_cjdnzl, May 22, 2:05 pm

I have just done as r.g said and used mozbackup and reinstalled FF but it has made no difference even typing here is slow it wasnt using previous version so the problem must be in the latest upgrade.
My computer is not like all yours with 200gb ram etc i only have 2gb win 7 and everything works well until now with the FF upgrade. Looks like i'm going back to Chrome after years of no probs with FF

geek_newbie5, May 22, 2:22 pm

make a backup of the settings on firefox. uninstall it with ccleaner and reboot then cclean the whole system and traces from the uninstall and reinstall firefox fresh and then import your settings again.
Also addons can cause these problems.

geek_intrade, May 22, 2:27 pm

done all that but no difference.
I am going to try upping ram to see if it loads faster.
Does it matter if I use ddr or ddr2 so long as they are all the same

geek_newbie5, May 22, 2:42 pm

Just tried writing something else but it just keeps freezing up. I am using another comp at the moment so going to try uninstalling FF and reinstall again after some maintainance like clean up etc.

geek_newbie5, May 22, 3:09 pm

still the same

geek_newbie5, May 22, 3:51 pm

geek_wickedtrader, May 22, 4:16 pm

Problem fixed have changed to Chrome and everything back to normal so as said the problem was FF 3.8

geek_newbie5, May 22, 4:43 pm

You have to use either DDR *or* DDR2 *or* DDR3. Run the program from crucial.com or install CPU-Z to check what RAM you have, how many slots, and speed options. 2GB is getting a bit cramped these days, with bigger programs.

geek_r.g.nixon, Oct 28, 3:03 pm

Share this thread