Push Schedule Stopped Working iPhone 5S

For the last 24 hours or so the push schedule on both my iPhone 5S and my iPad Air has stopped working for some reason. I haven't downloaded anything new or installed any updates so I'm at a loss really. I have two yahoo email addresses (one is an xtra.co.nz) and an iCloud address loaded, all three are set to 'push' but the tick in the in box is greyed out (on both devices) I am running iOS 8.3

I have tried pretty much everything I can think of including a back-up reset to last month, but that didn't work either. So I'm stuck now. I would really appreciate any advice. At the moment I have it on 'fetch' set at 15 minute intervals but I don't even think it's doing that since I only seem to get mail when I manually open the program and check it.

geek_trader_spence, Jun 24, 1:42 pm

Humm, from reading the Apple forums it appears this is a common-ish iOS 8.3 problem. No fix yet but it appears that a new upgrade is due any time now (ready for Apple Music) hopefully that will sort it if nothing else does.

geek_trader_spence, Jun 24, 5:59 pm

Did you try removing the accounts then re-adding them?

geek_vtecintegra, Jun 24, 6:12 pm

Yes, I tried that. I think the only thing I haven't tried is a full factory reset, but for obvious reasons I would rather that were a last resort.

geek_trader_spence, Jun 24, 6:52 pm

Well either something (or nothing) I have done appears to have done the trick and my mail is being pushed through to my mailboxes immediately once more. Hopefully iOS 8.4 won't cause more problems than it fixes! (My wifi still randomly drops out depending where I am in the house - annoying)

geek_trader_spence, Jun 26, 2:27 pm

i had the same problem on my iphone and ipad using imap email on push and it appears to be ok now, i suspect it was a problem with yahoo/xtra although their website said no problem with email it was only on those accounts i had a problem, me.com and hotmail were ok.

geek_sred69, Jun 26, 6:37 pm



Thanks for that, I did wonder afterwards if it was some weather related problem affecting the yahoo servers but as you say, there was nothing on the website so I wasn't sure. Hopefully it's all good now.

geek_trader_spence, Jul 19, 3:16 pm

Share this thread