Paradox security systems Battery replacement

kiwialan, Apr 11, 3:58am
Have a home security system with a flat battery, so instead of contacting ADT (AND A BILL OF $180) brought a battery from Jaycar for $34.00 and replaced it. Light still on so I think I need to reset, but cannot find out how to reset Can anyone help?

The battery is the correct one, system is about 15 years old with a spectra panel

Cheers Alan

pyro_sniper2002, Apr 11, 4:13am
Next time go to someone like Century Batteries and it will be even cheaper.


pheonix, Apr 11, 6:58am
Have you tried arming , then disarming panel?

pheonix, Apr 11, 7:01am
Otherwise some require you to hit the "mem" button and then the "clear" button

kiwialan, Apr 11, 8:59pm
Tried arming and disarming, tried mem and clear. Checked all battery connections Still shows battery as low, and cannot set the alarm at all - Just don't want to work.

hbhana, Apr 11, 10:24pm
I would do usual checks. Measure battery voltage with a multimeter and also double check you have connected the battery with the correct polarity.

cammey, Apr 13, 12:00am
Press TBL. A number comes up. 1 is flat battery.

8 is lost time. I bet its lost its time. Just dial in the time in 24 hour format while the 8 is lit, ie 1230 for half twelve.

kiwialan, Apr 13, 12:29am
That's a thought - I'll try that. But how do I get the 8 to light up?

cammey, Apr 13, 12:30am
Press TBL. It will light on its own if that is the fault. Then press 8. Then dial in time.

kiwialan, Apr 13, 12:39am
Hi, Tried that, no light came up on 8. Still shows fault as flat battery, even though it has been replaced. Could not get alarm to wrok, but by using force button it will Cheers Alan

cammey, Apr 13, 4:45am
Battery fuse blown. On main PCB.

tool_shop173, Feb 22, 4:04pm
Terminal leads around the right way?

Share this thread

Buy me a coffee :)Buy me a coffee :)