Parallel printer problem

I had an old parallel port Kyocera printer on a computer with Windows 7, and it's been working fine for the past 6 months. Then I had to move the computer while the house was being redecorated, and left the printer disconnected for a couple of weeks. Now reconnected, it shows as it always has (as KX Driver for universal printing) but will not print. Shows attempts to print as queued print jobs with "error". I have Puppy Linux dual booting on the computer and it won't print from that either. The printer works fine on another computer running XP. I have tried deleting and reinstalling with the same result. As the printer is obviously OK (works on another computer) I have assumed it must be a hardware problem. The LPT1 port shows as working correctly. What else can it be?

geek_rpvr, Mar 8, 9:04 pm

The cable or the socket, check you haven't unscrewed one of the hex nuts off the backplane.

geek_gyrogearloose, Mar 8, 9:07 pm

Checked cable is secure, and used the same cable to connect to other computer. I guess that just leaves the socket. Maybe I'll try one of those parallel to USB connectors, they're cheap enough.

geek_rpvr, Mar 8, 9:33 pm

a thought, when you unplugged the port. did you first uninstall the driver?, probably not, and obviously you've tried reinstalling the driver since
have you tried removing the LPT1 port in device manager and then cold start the machine again. cos it sounds like the port has a hang and I can't think of any other way to clear it, it won't do any harm to try
you will have to reinstall the printer driver after the port is found and activayed

geek_skin1235, Mar 8, 10:31 pm


This worked, many thanks. I had done these things already, but not in the order you suggested.

geek_rpvr, Mar 9, 12:49 pm

many times I've been scratching my head too, and then someone suggests something that makes it click, thanks for coming back, will add that to the bag of tricks

geek_skin1235, Jun 6, 10:07 pm

Share this thread