USB 3.0

My USB 3.0 slot doesn't recognize any USB 3.0 drive as a USB 3.0. works as USB 2.
I have win 7 and the slots are mounted direct on the Gygabyte motherboard (GA-B75M-D3V.)
Have uploaded new drivers and googled like mad. going quietly insane.

geek_cameragod, Feb 7, 1:47 am

so you have installed the USB 3.0 Driver from here?
http://www.gigabyte.co.nz/products/product-page.aspx?pid=4151#dl

geek_king1, Feb 7, 2:13 am

Are you using a USB 3.0 cable? The USB 2 cable will fit, but will only give USB 2 speed. Oh wait, these are on the motherboard and don't need a cable, duh.

geek_gyrogearloose, Feb 7, 2:39 am

Yes I tried the latest gigabyte USB 3 driver and gyrogearloose, I too am having plenty of "duh" moments :-)

geek_cameragod, Feb 7, 2:45 am

Perhaps try uninstalling the drivers for USB3 and then restart and reinstall?

geek_namtak, Feb 7, 2:57 am

Does your USB drive get recognised as USB3 on another machine or has it been misrepresented ?

geek_asmawa1, Feb 7, 3:06 am

Is your BIOS current? Try a later USB3 driver from Intel's site.

geek_gibler, Feb 7, 3:26 am

Yes current BIOS, yes drive's (Western Digital, Seagate and WD Red in Speedmaster case) work as USB 3.0 on other pc's, not on mine. the Gigabye driver is the Intel one. Have uninstalled restarted and reinstalled.
I normally enjoy hunting down stuff like this but it really has me stumped.

geek_cameragod, Feb 7, 4:15 am

happened to me too mate on my ASUS Mobo.
USB 3 would not work - rear were fine but using the jumpers to the front wouldn't; I tried everything, like you - but nothing would work - then out of the blue they started working one day when I was trying "again" *shrug*
This was over the course of a month I think.

geek_neoslowmo, Feb 7, 4:40 am

I've found USB 3.0 speed to be very underwhelming if that comforts you at all.

geek_schizoid, Feb 7, 5:13 am



Mines fine. Able to fully saturate an external HDD in writes (100MB/s), nice improvement over USB2.0's 20MB/s.

geek_lugee, Feb 7, 8:40 am



Would like to get the chance to find out ;-)

geek_cameragod, Feb 7, 7:56 pm

try linux live system

geek_intrade, Feb 7, 9:13 pm

i have had bluescreens as soon as i plugged in on usb 3 port and found the fix on the manufacturer site of my tool my usb 3 is fresco logic and on asus laptop model support site is only old drivers listed that cause error there recomendation has fixed my bluescreen .
http://www.ross-tech.com/vag-com/issues.html

i hunted down the driver number they mentioned, of course this is only fresco logic fix , and it seems a hardware problem , i sent 100s of error report to microcrap you would think they could add a fix to there generic driver also when they get the reports.

geek_intrade, Feb 7, 9:18 pm

Still no luck. Would like to get it working today so while I'm under the hood any suggestions appreciated.

geek_cameragod, Aug 31, 5:10 am