Apacer 16gb card - faulty?

socram, Feb 17, 9:11pm
The tab is unlocked and no matter what I try to do, when using it in a multicard card reader on the PC, I cannot erase files - or reformat the card.

It keeps saying it is write protected. I uncheck the properties to change from archive for individual files and folders but no luck there either. Nothing happens.

Any suggestions or has anyone else come across this? Is the card faulty (i.e. the locking tab not working). Folders and files have been copied from a lap top, not taken on a camera.

socram, Feb 17, 9:17pm
Just tried the card in the camera. It writes OK, but I still can't delete the files on the PC.


amphipod, Feb 17, 9:30pm
I have a no-name card which I use in a SD adapter, when the adapter tab said lock it was unlocked and vice versa,.

mgc54, Feb 17, 11:06pm
I had this issue with a Sandisk 2 gig card recently.
I wanted to copy more photos to it to display on a photo frame.
I googled the problem and came up with this solution which worked for me.
Its NOT the lock switch.
On the opposite side of the card from the lock switch there was a tiny notch, up towards the top near the gold pins.
The solution is to cover the notch with cellotape, it may take two layers.
Make sure its well stuck to the card so it does not detach in your reader.
Make sure you don't cover the gold pins.
Having done that I was able to delete, write and presumable format though I didn't try the latter.
Its a bit fidderly to do but this method worked for me.
See this photo, notch on my backup card too.
https://trademe.tmcdn.co.nz/photoserver/full/364874118.jpg

socram, Feb 18, 12:03am
Thanks for that. Sadly, that didn't work either - with the lock tab in either position.

AVG "Permanently shred files" didn't work, nor re-formatting the card.

mgc54, Feb 18, 1:28am
This is essentially my method? The tape used looks opaque? That may help. I found I needed two layers of clear sellotape. This is the original thread I got my "fix" from. https://answers.yahoo.com/question/index?qid=20080310092638AAj06k8

socram, Jul 30, 8:55pm
Thanks. Still no luck using a card reader connected to the PC.

So, I tried again on the laptop and it deleted OK! Moral is I suppose, don't give up, just try in different devices. (I'd loaded it up with stuff to transfer from Laptop to PC, so files were written from the lap top and also the camera.

Share this thread

Buy me a coffee :)Buy me a coffee :)