Can't open Chrome (Vista)

I deleted a few files a couple of days ago, one being a remote access file I thought I didn't need. Next time I turned the computer on it said "failed to connect to a Windows Service". I used a restore point and it worked for one day then went back to it this morning. This time I used an earlier restore point and it worked, but I can't get Chrome to open and it's the one I use all the time. I got a message to say Windows is closing the program. Can anyone help?

geek_gracie3, Apr 22, 11:21 am

geek_suicidemonkey, Apr 22, 11:22 am

What about all my bookmarks, etc?

geek_gracie3, Apr 22, 11:27 am

chrome will remember them during uninstall/reinstall usually

geek_king1, Apr 22, 11:55 am

If you've logged into Chome with your Google account (it asks you the first time you open it), it will have synced them.

geek_suicidemonkey, Apr 22, 11:58 am

I got it working. I was downloading updates and went into Computer, Local Disc C, Program Files, Google, Chrome, Application. I found two Chrome files, old and new. I clicked on new and everything went back to normal. I just hope it stays like that, lol.

geek_gracie3, Jan 25, 4:11 am

Share this thread