USB Ports not working.

gammelvind, Feb 8, 8:30am
I have a Toshiba running win7 home edition. Been working just fine up till today. Then suddenly neither of the two USB ports stop recognizing any device.
Using Google I found various suggestions to fix, ended by deleting all the USB drivers and reloading them, still no go. Any suggestions or is it time to go see the man?

r.g.nixon, Feb 8, 10:00am
See if there are any motherboard driver updates.


king1, Feb 8, 10:32am
turn off, remove battery and power, push hold power button for a minute or two. Reassemble and test.

lefty1234, Feb 8, 9:16pm
omg, thats what my toshiba windows 7 is doing. lol. lucky i found this thread. thanks guys .

gammelvind, Feb 9, 7:03am
Sadly, remove battery etc, drivers are up to date, ran several diagnostics and they all pass the USB ports, but they still don't work. Tried several items just in case one didn't work but no joy.
It's a Toshiba L500 laptop, just wondered if there was a crazy keystroke combination that I might have hit? Any ideas folks?

king1, Feb 9, 7:50am
battery out power off/unplugged for an hour or more. 9 times out of 10 this fixes it if it is ALL usb ports failing (with multiple devices of course). It's something peculiar about USB. Beyond that - out of ideas

gammelvind, Feb 9, 8:04am
Well I'll give that a go, kill tonight and try again in the morning. Yep no ports working, tried with camera, USB stick, portable hard drive and iPod, nothing.

cookee_nz, Feb 9, 10:15am
are they showing in the BIOS, and have you tried system restore to a date 2 or 3 days at least earlier than when they last worked?

gammelvind, Feb 10, 8:46am
Haven't tried that, have decided she's off to the mechanic tomorrow, guess it's time for its 100,000km service.

gammelvind, Aug 14, 10:06pm
Bugger, mother board fried, not worth getting repaired. Off to buy a new computer today, hard drive rescued and placed in an external enclosure so I can transfer the info to the new beast.

Share this thread

Buy me a coffee :)Buy me a coffee :)