Acer Aspire 5310. No Wifi on Linux Mint 18.3

rawill, Jun 3, 5:45pm
I decided to resurrect this old machine. The OS works fine, heaps better than the Vista it came with!

But as said above no wifi, no matter what drivers I put in.
Same thing happened under Ubuntu 16.04.

I have an old Aspire One ZG with Unbuntu running it, no problem with the wifi on it.

This model seems problematic, and that the on off button on the wifi is inactivated.

Also there is not wifi icon showing in the in the connections window where the ethernet connection shows up.
And which I am using.

a2znz, Jun 3, 7:08pm
Have you tried posting on the excellent Linux Mint Forum. To post you will have to register but it may well be that other people;e have experienced this problem and the answer has been give on on the Forum.

http://www.linuxmint.com/forum/


agarn, Jun 3, 7:32pm
In Mint
from Menu Administration
go to; Driver manager.
your wifi should be listed there.
check the appropriate driver and apply changes.
Other than that ,it could be a hardware fault

rawill, Jun 3, 8:04pm
Yes a2znz, I am on the Mint forum.
Yes agarn, I have done that, and use the terminal command to get new updates etc as well.

It was not a hardware fault under Vista, which is now gone off the computer.
There is indeed some incompatibility between the computer and Linux.

gsimpson, Jun 3, 10:26pm
You could try a USB wifi dongle

ianab, Jun 4, 7:45pm
This ^

A USB wifi dongle that supports Linux will set you back about $10.

rawill, Nov 4, 8:17pm
Found the issue, it was to do with the driver, I had selected Broadcomm, or similar, but it was the next one down on the list. I had tried that before, but with a version of Mint that needed to be "purged" first.

Share this thread

Buy me a coffee :)Buy me a coffee :)